Community Server Upgrade Hell

This last week I was tasked with upgrading a Community Server 1.1 install to 2.0.  I was expecting a simple process after navigating the seas of .Text to CS 2.0, but I forgot to “knock on wood”.

I ran the upgrade script as indicated in the upgrade instructions and got about 15 separate errors.  I don’t remember what they all were, but there was about three missing fields in various tables that I had to add before the script would complete successfully.

Once that was done, I copied the new web files over the old ones, and tried browsing to ye’ ol’ default.aspx which resulted in a Yellow Page of Death.

I assumed that the CS website wasn’t the problem, and could assume it was my database installation, since I had a gazillion errors on install.  I booted up SQL Profiler and filtered on “TextData” for “%cs_%” and “%aspnet_%”, which would only grab sprocs called in Community Server (all sprocs start with either aspnet_ or cs_).

After starting Profiler, I browsed to default.aspx again and watched what happened.  Each sproc that was called I compared against my blog and compared the results.  By doing this I found the following three problems:

  1. All my users were missing from the cs_Users table. I was able to reassemble them by looking at the aspnet_users for the MembershipID, and looked through the cs_Posts table to find the UserID. I tried to look at a backup, but that was another stupid problem I ran into…
  2. postconfiguration must not be 0 for each post in the cs_Posts table. I changed them to 11. Not sure why 11 and not 1 or 2 or 3. My blog had 11 for each post, so there you go.
  3. usertime must not be null in cs_Posts, so I set it equal to the postdate.

Leave a Reply

Your email address will not be published. Required fields are marked *